Set the MID Server version

You can specify which version the MID server should upgrade to using a property.

Before you begin

Role required: admin

About this task

ServiceNow does not recommend pinning the MID Server to a specific version for a significant amount of time, especially if you upgrade the instance. Under most circumstances, you should let the instance determine which MID Server version to use.

These properties control the MID Server version:
  • mid.buildstamp

    The mid.buildstamp property identifies the MID Server version with an identifier based on the date of the build. This property uses a date and time format of yyyy-mm-dd-hhmm.

    The MID Server checks for version information hourly. If no override version is configured, the MID Server looks at the mid.buildstamp property for the version to use. This property resets itself to the default version (the version that matches your instance version) when the instance is restarted or upgraded, so any user changes are lost at that time.

  • mid.version.override

    Use this property to set an override condition for the current MID Server version. When the MID Server checks the version each hour, it looks at the mid.version.override property first. If this property is empty, the MID Server will get its version information from the mid.buildstamp property. If an override version is configured, the MID Server uses this value and ignores the version information in the mid.buildstamp property. This override value remains when the instance is restarted and is passed to the MID Server. However, the version in the mid.version.override property is deleted during an upgrade, allowing the MID Server to reset itself to the version in the mid.buildstamp property.

    The MID Server cannot be upgraded until the parameter is cleared.

Note: Downgrades are only possible within the same major release, such as Helsinki or Istanbul.

Procedure

  1. In the Navigation pane filter, type sys_properties.list.

    The list of system properties appears.

  2. Click New.
  3. Type mid.version.override in the Name field.
  4. Enter a description, such as, Set an override value for the current MID Server version.
  5. Enter a version for the MID Server to use that is different from the version ServiceNow has selected in the mid.buildstamp property.

    The date and time format is yyyy-mm-dd-hhmm.

  6. Click Submit.