Close
Thank you for your feedback.

Exceptions to browser support

Exceptions to browser support

Certain applications and features in the Helsinki release have browser requirements that differ from the list of browsers generally supported by the ServiceNow platform.

Exceptions to the browser requirements

Table 1. Platform browser exceptions
Platform featuresDetails
Connect release notes
  • The latest public release of Firefox or Firefox ESR
  • The latest public release of Chrome
  • Safari version 6.1 and later
  • Internet Explorer version 10 and later
    • Edge mode is supported.
    • Compatibility mode is not supported.
    • Setting Security Mode to High (via the Internet Options > Security tab) is not supported.
    • Internet Explorer 11 is susceptible to memory leaks, which may impact performance, especially in Windows 7.
Dependency Views release notes

The Dependency Views module supports the latest version or service pack of the following browsers:

  • Firefox with the latest ESR
  • Chrome version 25 or later (latest version recommended)
  • Safari version 6 or later
  • Microsoft Internet Explorer (IE), with these requirements and limitations:
    • Dependency Views requires IE version 9 or later.
    • You cannot export images from a Dependency Views map using Internet Explorer as your browser.
    • When you save a map view, Dependency Views does not make a thumbnail image. You can navigate to the saved map view using the version number.

Email and notifications release notes

To preview notifications, Internet Explorer version 9 or later is required if you want to use Internet Explorer.

Lists release notes

  • The latest public release of Firefox or Firefox ESR
  • The latest public release of Chrome
  • Safari version 6.1 and later
  • The latest public release of Microsoft Edge
  • Internet Explorer version 10 and later
    • Edge mode is supported.
    • Compatibility mode is not supported.
    • Setting Security Mode to High (via the Internet Options > Security tab) is not supported.

Service Portal release notes
  • Modern browsers
  • Internet Explorer version 10 and later
Visual Task Boards release notes

  • The latest public release of Firefox or Firefox ESR
  • The latest public release of Chrome
  • Safari version 6.1 and later
  • Internet Explorer version 10 and later
    • Edge mode is supported.
    • Compatibility mode is not supported.
    • Setting Security Mode to High (via the Internet Options > Security tab) is not supported.
    • Internet Explorer 11 is susceptible to memory leaks, which may impact performance, especially in Windows 7.
  • Access Visual Task Boards on your mobile device using either a browser or the native mobile app. See Supported devices for the mobile browser or Supported devices for the mobile app for more information.

Table 2. ITSM browser exceptions
ITSM applicationsDetails
Guided setup release notes

Use one of the following browsers with the guided setup:

  • Internet Explorer 10 or later
  • Google Chrome 33 or later
  • Mozilla Firefox 28 or later
  • Apple Safari 6 or later

On-Call Scheduling release notes

The updated calendar view is available on only Internet Explorer 10 or later. Any older versions of Internet Explorer display the legacy calendar view.

Table 3. Business Management browser exceptions
Business Management applicationsDetails
Demand Management release notes

If you are using Internet Explorer, version 11 or later (including Edge) is required to use all aspects of the workbench.

Financial Management release notes

If you are using Internet Explorer, version 11 or later (including Edge) is required to use all aspects of the workbench.

Project Management release notes

If you are using Internet Explorer, version 11 or later (including Edge) is required to use all aspects of the portfolio, program, and project workbenches.

Resource Management release notes

If you are using Internet Explorer, version 11 or later (including Edge) is required to use all aspects of the workbench.

Table 4. Service Management browser exceptions
Service Management applicationsDetails
Facilities Service Management release notes

If you are using Internet Explorer, you must use version 9 or later to use the Enterprise Move Planning tool and the interactive maps. You can also use any of the other generally supported web browsers.

Field Service Management release notes

The central dispatch feature is supported on the following browsers:

  • The latest public release of Firefox
  • The latest public release of Chrome
  • Safari version 6 and later
  • Internet Explorer version 10 and later

HR Service Management release notes

HR Service Portal requires Internet Explorer version 10 or later. The Manage HR Catalog and Manage HR Skills modules require Internet Explorer version 9 or later.

Table 5. Performance Analytics and Reporting browser exceptions
Performance Analytics and Reporting featuresDetails
Dashboards release notes

Responsive dashboards are not supported on Internet Explorer 7 and 8.

Performance Analytics release notes

The animations that play when a visualization loads are not supported in Internet Explorer.

Products > Release Notes; Versions > Helsinki