Thank you for your feedback.
Form temporarily unavailable. Please try again or contact docfeedback@servicenow.com to submit your comments.
Versions
  • London
  • Kingston
  • Jakarta
  • Istanbul
  • Helsinki
  • Geneva
  • Store
Close

Supported browsers for Dependency Views

Supported browsers for Dependency Views

The latest version or service pack of internet browsers are required to view and manipulate Dependency Views maps.

The Dependency Views module supports the latest version or service pack of the following browsers:
  • Firefox with the latest ESR
  • Chrome latest version
  • Safari version 8 or later (latest is recommended)
  • Microsoft Internet Explorer (IE) version 11 and Microsoft Edge.

The Dependency Views module is not supported on tablets and on mobile devices.