Supported browsers for Dependency Views

The latest version or service pack of internet browsers are required to view and manipulate Dependency Views maps.

The Dependency Views module supports the latest version or service pack of the following browsers:
  • Firefox with the latest ESR
  • Chrome version 25 or later (latest version recommended)
  • Safari version 6 or later
  • Microsoft Internet Explorer (IE) version 9 or later

The Dependency Views module is not supported on tablets and on mobile devices.