Istanbul Patch 2 Hot Fix 1

The Istanbul Patch 2 Hot Fix 1 release contains fixes to these problems.

For Istanbul Patch 2 Hot Fix 1:
Build date: 04-14-2017_1758
Build tag: glide-istanbul-09-23-2016__patch2-hotfix1-04-14-2017

For more information about how to upgrade an instance, refer to Upgrade to Istanbul.

For more information about the release cycle, see the ServiceNow Release Cycle. For a downloadable, sortable version of Istanbul fixed problems, see KB0598935.
Note: This version is approved for FedRAMP.

Fixed problem in Istanbul Patch 1 Hot Fix 1

Problem Short description Description Steps to reproduce

Platform Security

PRB691031

Scoped Admin – Error messages appear when navigating to a group that grants a scoped role Many error messages appear when a user navigates to a group that grants a scoped role, if the user does not have the proper role to assign it.
  1. Create a new scoped application.
  2. Create two roles: sn_app_user and sn_app_admin. Make sn_app_user only assignable by sn_app_admin.
  3. Give one user sn_app_admin. Do not give this role to the system admin.
  4. Create a group that assigns the role sn_app_user.
  5. Turn on scoped administration.
  6. As admin (not scoped admin), navigate to the group you created.
  7. Refresh the page.

Error messages appear.

Fixes included with Istanbul Patch 2 Hot Fix 1

* Unless any exceptions are noted, you can safely upgrade to this release version from any of the versions listed below. These prior versions contain PRB fixes that are also included with this release. Be sure to upgrade to the latest listed patch that includes all of the PRB fixes you are interested in.