SCCM 2012v2 integration

This version is written based on SCCM 2012, and requires the Integration - Microsoft SCCM 2012 v2 version 4.1.0 plugin.

This version has the same features as the Microsoft SCCM 2007 plugin, but for SCCM 2012.