Supported browsers for Event Management

The latest version or service pack of Internet browsers are required for Event Management.

For general support:
  • Firefox version 31 ESR and version 38 or later
  • Chrome version 43 or later
  • Microsoft Internet Explorer (IE) 7 or later
  • Safari version 6.1 or later
For UI16 support:
  • Firefox version 31 ESR and version 38 or later
  • Chrome version 43 or later
  • Microsoft Internet Explorer (IE) 9 or later
  • Safari version 6.1 or later