MID Server system requirements

MID Servers have several system requirements.

The following requirements are for the use of MID Servers with the ServiceNow Discovery and Orchestration products.

Java version support

The MID Server installs with JRE version 1.8. If you upgrade with a MID Server using JRE 1.6, the system automatically upgrades that MID Server to use version 1.8. Both the 32 bit and 64 bit MID Server use JRE 1.8.

MID Server minimum suggested configuration

The following configuration is the minimum suggested configuration for a MID Server.
  • 8GB of available RAM per MID Server
  • 2GHZ CPU with a multicore CPU
  • 4GB of disk space per MID server
  • 1024MB of memory. For instructions on configuring the MID Server memory allocation, see Set the MID Server JVM memory size.
  • Can be installed with other services, depending on the server utilization and resource availability

MID Server supported systems

The following systems support the MID Server.
  • Windows Server

    Service Mapping can discover Windows-based servers only using MID Servers installed on Windows Servers.

    • Windows Server 2003
    • All Windows Server 2008 and 2012 editions are supported.
    • Virtual machines
    • 64-bit systems

    .NET Framework version 3.5 is required for Service Mapping support.

  • Linux
    • Virtual machines
    • 64-bit systems
    On 64-bit Linux systems, you must install the 32-bit GNU C library (glibc). The installation command for CentOS is: yum install glibc.i686